Wanderlodge Owners Group

Wanderlodge Owners Group (https://www.wanderlodgeownersgroup.com/forums/index.php)
-   Engine (https://www.wanderlodgeownersgroup.com/forums/forumdisplay.php?f=15)
-   -   DDEC 1 Check Engine Light Confusion (https://www.wanderlodgeownersgroup.com/forums/showthread.php?t=26205)

Alfa 07-20-2016 05:41 PM

DDEC 1 Check Engine Light Confusion
 
The last time to put my coach in storage, I noticed that the check engine light was very faintly blinking when idling. All of the gauges looked normal, so I shut her down and checked all of the fluid levels.

Everything looked normal, oil, transmission, and a nice green site glass. So I decided to tap on the side of the coolant tank and it sure sounded hollow, so I decided to get some Fleet charge and add about a half gallon of 50/50 mix. I ran the engine for a few minutes and no check engine light but the tank still sounded hollow, so I added about a gallon more mix (with about a pint pouring on my head and shoulders when I wasn't paying attention to the funnel...)

Now when I start the engine, I get a solid check engine light. I also noticed that the lower half of the sight glass is no longer green, but more the color of the Fleet charge. So I am thinking that I need to add more coolant, but I thought that I would press the engine test button and decode the blinky lights to see what my DDEC 1 was complaining about.

So, I stared at the blinky lights and they didn't make much sense to me. The manual says that there will be about a 3 second pause between codes, which will be one or more flashed for the first digit, then a 1/2 second pause, then one or more flashes for the second part of the code. Mine seems to be a little different.

Can anybody help me understand what my DDEC 1 is trying to tell me? In the video, the engine is running at normal idle. Near the end of the video, I show the temp and oil pressure gauges and switch to high idle to show the oil pressure moving.



Thanks!

Diego

Alfa 07-20-2016 05:44 PM

1 Attachment(s)
Here are the engine codes.

Mike Hohnstein 07-20-2016 07:13 PM

Check all ground points.

Alfa 08-14-2016 10:40 AM

Problem mostly went away when I reseated the connectors going into the DDEC box on top of the engine. Will get load tested and check grounds anyway since I still have some random (or maybe not random...) check engine flashing

Alfa 08-25-2016 09:20 PM

For completeness, in case someone is reading this thread in the future, here is a link to what I discovered when plugging in a diagnostic code reader (Pro Link 9000) to pull the codes.

http://www.wanderlodgeownersgroup.co...7&postcount=30


All times are GMT -4. The time now is 03:03 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.