View Single Post
  #6  
Old 01-08-2009
Lee Davis's Avatar
Lee Davis Lee Davis is offline
Senior Member
 
Join Date: Feb 2008
Location: Wherever we are parked
Posts: 1,652
Default

Oops, I may be in trouble then. I have used the electric element a time or two and it has worked fine (usually gives me plenty of hot water) except yesterday I only had enough for one shower after running it for two hours. It's possible I have screwed up the element. How does one check that out or will I just have to wait until I fix the fluid leak and see if the electric gives me hot water. I guess we'll be taking showers in the bath house until this is resolved.

I know it is Aquahot coolant, not engine coolant as I replaced the engine coolant with the Lifetime Blue stuff and this leak is not blue.

And to make matters worse, I have found a diesel line dripping as well now. It is the one in the front of the diesel burner unit under it so I took the hose off and cut off a little of it (in case the end was bad) and put it back on but still dripping. I watched an Aquahot guy work on mine about a year ago when we were in FL and I vaguely remember these things often leak where the metal tubing goes into the burner unit. He commented that they did that differently in the newer units. Diesel leaks were supposed to have been taken care of when I had the Aquahot recall done by the Bluebird folks (Coachworks) in Ft Valley in the Spring.

I have to admit, these may be great units but I am getting a little tired of mine.
__________________
Lee and Jacque Davis - Full Timers

Lee - 423-292-5767 or Jacque 423-262-9569
or lnjdavis@gmail.com Please call or email instead of private messages


1995 BMC 37
300 HP Cummins 6CTA 8.3 Turbocharged Diesel
Boldly Going Nowhere
http://www.bbirdmaps.com/index.cfm #117
Reply With Quote