Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > Transmission

Transmission Discussion of preventative/corrective maintenance and other technical issues regarding your coach's transmission.

Site Search:
Reply
 
Thread Tools
  #1  
Old 05-07-2009
Rob Robinson's Avatar
Rob Robinson Rob Robinson is offline
Forum Moderator
 
Join Date: Dec 2007
Location: Victoria
Posts: 4,386
Default Tranny Won't Shift

Need some advice guys. I've just now arrived home from Randy's and my tranny appears to be acting up. If I start up the engine and put it in drive it shifts Ok until I put it in neutral and then try shifting it back to drive. It remains in neutral and won't shift into drive. I have to turn the engine off and restart before it will shift into drive. The red check tranny light has come on and when I switch it over to 'check tranny' it gives out a three light code. The code is two quick short blinks followed by a break and then one more quick short blink. I'm headed to an Allison shop tomorrow and would like to go with any advice/info you guys might be able to throw my way.
__________________
Rob Robinson
Victoria, British Columbia
1999 LXi
Moderator

Last edited by Rob Robinson; 05-08-2009 at 01:06 AM.
Reply With Quote
  #2  
Old 05-08-2009
thomas_sorrentino's Avatar
thomas_sorrentino thomas_sorrentino is offline
Senior Member
 
Join Date: Jan 2008
Location: Bedford Hills, NY
Posts: 929
Default

Hi Rob,

My coach did the same thing when I first got it. I don't remember what the code was. At the time I had read on the forum it was probably the ground wire needed cleaning at the tranny. I had to take it to Allison for something else and had them check it. Sure enough, thats what they said, dirty connections. You might want to check it yourself and save some money so you can come out this way and visit!
__________________
Tom Sorrentino
1987 PT38
Bedford Hills, NY
Westchester Sandblast
Reply With Quote
  #3  
Old 05-08-2009
Randy Dupree's Avatar
Randy Dupree Randy Dupree is offline
Forum owner
 
Join Date: Dec 2007
Location: Port St Joe,Fl
Posts: 36,179
Default

Rob,that ground cable is a braided strap that bolts to the bracket that holds the external tranny filter to the curb side of the tranny
its a major PITA to get to.
I suggest adding a new cable from the same area and running it to the engine buss bar near the exhaust mainfold and the engine batteries.
WWRD?
__________________
DO NOT SEND PM
email me at randy@randydupree.com only.

Randy Dupree
2000 LXI 43
Bainbridge,Ga.
Port St Joe Fl.
www.buybyebluebird.com

randy@randydupree.com
Reply With Quote
  #4  
Old 05-08-2009
fxdwg fxdwg is offline
Senior Member
 
Join Date: Mar 2008
Location: okc
Posts: 3,843
Default

If the diagnostics are like most cars & light trucks, you're getting a code # 21. Now what that means, I have no idea, but maybe somebody can tell you.
__________________
John
96 WTOS 42'
OKC USA!


don't waste your time with a usa-spec ipod adapter- poor products with poor support
Reply With Quote
  #5  
Old 05-08-2009
Freight Train Freight Train is offline
freight train
 
Join Date: Nov 2008
Location: Washington
Posts: 48
Default trasmission

Whys you rpms in natutal???? Bob
__________________
Bob Gregg
Freight Train
'86 - 40
gregg@tfon.com
Port Angeles, WA
Reply With Quote
  #6  
Old 05-08-2009
Rob Robinson's Avatar
Rob Robinson Rob Robinson is offline
Forum Moderator
 
Join Date: Dec 2007
Location: Victoria
Posts: 4,386
Default

Quote:
Originally Posted by Freight Train View Post
Whys you rpms in natutal???? Bob
Bob I didn't notice what rpms I had in neutral but I'm sure it was normal or I would have noticed the engine sound being different.
__________________
Rob Robinson
Victoria, British Columbia
1999 LXi
Moderator
Reply With Quote
  #7  
Old 05-08-2009
Rob Robinson's Avatar
Rob Robinson Rob Robinson is offline
Forum Moderator
 
Join Date: Dec 2007
Location: Victoria
Posts: 4,386
Default

Took the bird into DD/Allison shop today but the tech wasn't available. That was OK as I planned on changing out the Transynd anyways. While the mech was under the bus I had him install a new ground strap from the tranny bell housing directly to the negative side of the start batteries. Bottom line....the problem still exists. Hopefully the tranny tech can shed some light on this next week. I'll keep you posted.
__________________
Rob Robinson
Victoria, British Columbia
1999 LXi
Moderator
Reply With Quote
  #8  
Old 05-08-2009
curtsprenger's Avatar
curtsprenger curtsprenger is offline
Senior Member
 
Join Date: Jan 2008
Location: Anaheim Hills, CA
Posts: 3,889
Default

Quote:
Originally Posted by Rob Robinson View Post
Need some advice guys. I've just now arrived home from Randy's and my tranny appears to be acting up. If I start up the engine and put it in drive it shifts Ok until I put it in neutral and then try shifting it back to drive. It remains in neutral and won't shift into drive. I have to turn the engine off and restart before it will shift into drive. The red check tranny light has come on and when I switch it over to 'check tranny' it gives out a three light code. The code is two quick short blinks followed by a break and then one more quick short blink. I'm headed to an Allison shop tomorrow and would like to go with any advice/info you guys might be able to throw my way.
Rob,
My info...not sure it pertains to your application...Code 21 means the Throttle Position sensor failed low/high... a solenoid shorted to ground.
__________________
Curt Sprenger
1987 PT38 8V92 "MacAttack Racing"
1974 FC31 534 gas engine, air brakes (sold)
Anaheim Hills, Calif.
Do Not Send PM (Private Messages) Please
curtsprenger@gmail.com
Reply With Quote
  #9  
Old 05-08-2009
Rob Robinson's Avatar
Rob Robinson Rob Robinson is offline
Forum Moderator
 
Join Date: Dec 2007
Location: Victoria
Posts: 4,386
Default

thank you Curt. Where do you find these codes????
__________________
Rob Robinson
Victoria, British Columbia
1999 LXi
Moderator
Reply With Quote
  #10  
Old 05-09-2009
curtsprenger's Avatar
curtsprenger curtsprenger is offline
Senior Member
 
Join Date: Jan 2008
Location: Anaheim Hills, CA
Posts: 3,889
Default

Quote:
Originally Posted by Rob Robinson View Post
thank you Curt. Where do you find these codes????
I'll send to your email address the trans. code list that I have. I can upload it to this Forum but not sure where I should put it. And I do not know if it pertains to your Trans.
__________________
Curt Sprenger
1987 PT38 8V92 "MacAttack Racing"
1974 FC31 534 gas engine, air brakes (sold)
Anaheim Hills, Calif.
Do Not Send PM (Private Messages) Please
curtsprenger@gmail.com
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The tranny in the bus goes bump-bump-bump gcyeaw Transmission 161 01-10-2009 09:36 PM
Do Not Shift light? konehd PT & WB (Twin Axle Pusher Unique Issues) 11 11-09-2008 11:08 PM

Web Search:

All times are GMT -4. The time now is 06:28 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.