Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > Generators

Generators In this forum we will try to answer any of your questions about the different model generators that can be found on Blue Bird coach's.

Site Search:
Reply
 
Thread Tools
  #1  
Old 02-13-2019
GFamHotel&Spa GFamHotel&Spa is offline
Member
 
Join Date: Jan 2017
Location: Las Vegas
Posts: 31
Default Transfer switch problems?

I have an 86 PT40. I just plugged in to shore power and get a buzzing from my panel and the polarity reversed red lights. Everything was working fine. It works fine on my GenSet. I am thinking transfer switch? Where is it located and how would I test it?
__________________
Bill Guzenski
Las Vegas, Nevada
1986 PT-40
Reply With Quote
  #2  
Old 02-14-2019
kg4rrx's Avatar
kg4rrx kg4rrx is offline
Senior Member
 
Join Date: Feb 2018
Location: Fayetteville
Posts: 571
Default

Is this the first time plugging in at this location? Are you using a surge protector?
__________________
Chris Henry
Fayetteville, GA
87FC
kg4rrx@gmail.com 404-547-1951
Reply With Quote
  #3  
Old 02-14-2019
GregOC GregOC is offline
.
 
Join Date: Dec 2018
Location: R
Posts: 392
Default

The red light reverse polarity warning tested the incoming shore power.maybe you have reversed polarity on shore poc and not on genset output.

A good read is 'no~Shock~Zone RV Electrical Safety '
Too many variables and prior owner hacks. Also, learn the path current alternates thru. and the dynamic of the other big issue 'dropped neutral

I replace transfer switches as a PM when I get a bus. Only 130 bucks at camp world. I test electric prior to hook up and no longer use surge protect devices. Most of these guys use them. Probably safer to use one
__________________
Greg
Reply With Quote
  #4  
Old 02-14-2019
dennis hight dennis hight is offline
Senior Member
 
Join Date: Aug 2009
Location: mancos co.
Posts: 454
Default

I would check the shore power source first,
__________________
Dennis&Debbie Hight 91 wb mancos co.
Reply With Quote
  #5  
Old 02-14-2019
GFamHotel&Spa GFamHotel&Spa is offline
Member
 
Join Date: Jan 2017
Location: Las Vegas
Posts: 31
Default

So thank you guys for your answers and I am sorry for the delay. This is NOT the first time at this location. It is happening at my home source that worked fine before I went on this week long trip.
__________________
Bill Guzenski
Las Vegas, Nevada
1986 PT-40
Reply With Quote
  #6  
Old 02-14-2019
sfedeli's Avatar
sfedeli sfedeli is offline
Senior Member
 
Join Date: Jan 2008
Location: Hershey
Posts: 3,175
Default

There is a poor connection somewhere...remember a shore cord relies on (3) connections for each leg, the ground and neutral. That is a total of 12 possible connections that could be corroded or loose. Start with your plug on the side of the garage or house, then each end of the cord itself. Is it original? Have you replaced the ends? Is the copper clean on the plug prongs or slightly charred...
__________________
Shane Fedeli
85PT40
Hershey, PA

"Savor the wine of youth, for it is a drink that can be consumed only once”
shanefedeli@gmail.com
717-645-4912
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transfer switch issue? Jerry_94110 PT & WB (Twin Axle Pusher Unique Issues) 8 12-03-2017 02:21 PM
transfer switch Don Meyer Electrical 11 09-27-2017 09:41 AM
Is my transfer switch going bad? sanibel Electrical 17 04-16-2017 01:07 PM
Transfer Switch matthewmccaskey General 11 02-04-2016 07:10 AM
Transfer Switch Somervillebus Electrical 4 03-07-2010 12:28 PM

Web Search:

All times are GMT -4. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.