Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > Electrical

Electrical Discussion of preventative/corrective maintenance and other technical issues regarding your coach's electrical system.

Site Search:
Reply
 
Thread Tools
  #1  
Old 02-13-2009
lonestar382's Avatar
lonestar382 lonestar382 is offline
Senior Member
 
Join Date: Mar 2008
Location: Prosper
Posts: 153
Default faulty taillights

On my 96' PT42, I am trying to get all my tail lights working. I replaced all the bulbs in the curb side lights, only to find that nothing was different. So, I found that there was no 12volt power to the sockets that werent working.

Is this a problem with the wiring harness? Connectors? Dont know where to start. Has anyone had to replace the harness for the taillights?


Thanks
__________________
Corey, and the kids with two worthless muts
1996 PT42 60 Series (SOLD)
Prosper, TX/Osage Beach, MO
Reply With Quote
  #2  
Old 02-13-2009
dwjones75 dwjones75 is offline
Member
 
Join Date: Jan 2008
Location: Hoover
Posts: 46
Default 96 Taillights

I had the same problem. Had to rebuild the multipin connectors attached to

the engine cover. Got the tool and the replacement male and female pins at a local truck parts company. Was not an easy job.


Don Jones
96 wanderlodge
__________________
Don Jones
96 Wanderlodge
Hoover, AL
Reply With Quote
  #3  
Old 02-13-2009
lonestar382's Avatar
lonestar382 lonestar382 is offline
Senior Member
 
Join Date: Mar 2008
Location: Prosper
Posts: 153
Default

Don,

Thanks for the info. I guess I'll start looking at the connectors you referenced and see if that is where my problem lies.

Thanks
__________________
Corey, and the kids with two worthless muts
1996 PT42 60 Series (SOLD)
Prosper, TX/Osage Beach, MO
Reply With Quote
  #4  
Old 02-14-2009
max hendrix's Avatar
max hendrix max hendrix is offline
Senior Member
 
Join Date: Jun 2008
Location: Weatherford
Posts: 685
Default

Be sure to check your ground. All your lights quitting at once sounds like a grounding problem.
__________________
Max Hendrix
Weatherford Texas

96 BMC 40' Sold
2008 HaulMark Super C S&S
Freightliner Chassis w/ 515hp S60 & 12sp Ultrashift
Reply With Quote
  #5  
Old 02-14-2009
Stephen Stephen is offline
Senior Member
 
Join Date: Dec 2007
Location: Niagara Falls
Posts: 3,345
Default

if you need 3 pin weatherpack connectors we have some
call 888 8864288
Stephen
__________________
Have a Great Day
Stephen Birtles
97BMC37

Email stephen@dupreeproducts.com
www.dupreeproducts.com
Telephone 888 668 4288
cell 716 220 1267
Please use email or telephone to contact
Reply With Quote
  #6  
Old 02-14-2009
lonestar382's Avatar
lonestar382 lonestar382 is offline
Senior Member
 
Join Date: Mar 2008
Location: Prosper
Posts: 153
Default

Not all of the lights quit. 4 or 5 bulbs in each assembly work fine.

Stephen, thanks, as soon as I have time to get in there and figure out what I need I will call you.

Thanks
__________________
Corey, and the kids with two worthless muts
1996 PT42 60 Series (SOLD)
Prosper, TX/Osage Beach, MO
Reply With Quote
  #7  
Old 02-14-2009
BCRoamer BCRoamer is offline
Senior Member
 
Join Date: Apr 2008
Location: Boulder City
Posts: 318
Default

I had a terrible time getting all my taillights to work. The units on my coach are Volvo and the problem turned out to be bad connections between the harness coming into the taillight assemply and the spider that mounts the bulbs.

I ended up replacing the connector, cleaning all the corrosion off the male end and the made sure I cripped everything down tight.

The whole taillight issue ranks right up there with the biggest pain in the posterior of the work I've done to my coach.
__________________
Lance & Jan Crowley
1993 WB #104663 (SOLD)
Boulder City, NV
Reply With Quote
  #8  
Old 02-15-2009
Bumpersbird's Avatar
Bumpersbird Bumpersbird is offline
Senior Member
 
Join Date: Jan 2008
Location: Fayetteville
Posts: 2,185
Default

Here's a new lens and circuit board.

I've replace 2 of 4 lenses & boards.

If your problem is in the back, these boards are good to have on hand.

OEM lens to expensive, DOT approved after market good enough, when I bought the boards they told me that all were OEM (Volvo parts) new. Ask before you buy.

I bought mine on e-bay.

The auction below is listed only as a refrence to the proper lens and boards for a 1995 PT -42.

They should fit most or some early to mid 90's Birds. PT's SP's????? others??/(&b%WW#E

Make sure before you buy

I say they fit, actually you have to trim one side of the lens. A band saw works well for this. Other than that they fit easily. The plugs wouldn't be hard to replace if needed.





http://cgi.ebay.com/ebaymotors/Volvo...WDVWQQtcZphoto

http://cgi.ebay.com/ebaymotors/Volvo...WDVWQQtcZphoto


Kurt Horvath
95 PT 42
10AC
Attached Thumbnails
Click image for larger version

Name:	3518164.jpg
Views:	183
Size:	24.6 KB
ID:	1284   Click image for larger version

Name:	3518163.jpg
Views:	169
Size:	23.5 KB
ID:	1285  
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAT 3208 faulty temperture gauge or sending unt? kgallender Engine 6 01-12-2009 09:16 PM

Web Search:

All times are GMT -4. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.