Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > LX and LXI (Unique Issues)

LX and LXI (Unique Issues) If you have a unique issue with your LX or LXI model coach and it can't be answered in one of the other forums here, then this is where you can list it, WITH THE EXCEPTION OF THOSE ISSUES INVOLVED WITH ANY LAWSUIT.....list your LX and LXI Parts here too.

Site Search:
Reply
 
Thread Tools
  #1  
Old 10-18-2014
al perna al perna is offline
Senior Member
 
Join Date: Oct 2009
Location: ormond fla
Posts: 2,258
Default LXI SUSPENSION

Hello Wog ,

Quick question here do the WB share the same suspension as the LXI ?

you see I just don t understand how we continue to have a issue with our Ride Height . at this point we have replaced what I feel are all of the parts associated with the ride height .
air bags
HCV
shocks
pan rod

had the coach over to Josams twice over the past year and both times they say they can not figure it out or get her level all around .

all air springs are at 8"+-3/16

I wonder if the pan rod is at the root of our issue here . now Jsams said it s only purpose is to hold the body over the axle , and it is true while tracking straight she is lined up but it is when we turn that this alignment goes astray , that is the body shifts left or right depending on the turn .

Is it possible the pan hard needs adjusting and if how is this done ?

any wisdom here would be appreciated
__________________
AL & ERIKA

2000 LXI Single Slide (sold)
1999 Prevost Vantare 45

Ormond Beach, Florida
PLEASE DO NOT PM ME
alperna@yahoo.com
386 290 3444
www.fastcubes.com
Reply With Quote
  #2  
Old 10-18-2014
giderich's Avatar
giderich giderich is offline
Senior Member
 
Join Date: Jan 2008
Location: Rolla
Posts: 3,117
Default

Al, look for broken 'thru bolts' on the ends of the Panhard rod.

http://www.pbase.com/iamflagman/image/40441402

Also look for a failed and/or broken Panhard Rod.

Check for broken welds on frame and brackets on each end of the Panhard Rod.

Do you hear any loud popping or creaking sounds when performing "S" turns?

I know you have replaced the Panhard Rod recently, but something is wrong...
__________________
Dick & Patsy Gideon
1999 43 LXI Single Slide Body # F124510
2005 JEEP Liberty Limited CRD (diesel Toad)
SOLD 89 FC in 2012; SOLD 88 WB in 2016
Rolla, MO 65401
Reply With Quote
  #3  
Old 10-18-2014
Bill Pape's Avatar
Bill Pape Bill Pape is online now
Administrator
 
Join Date: Jan 2008
Location: Commerce
Posts: 11,428
Default

check the shock mounts & bushings
__________________
Bill & Patty
1988 FC, Silver Edition
Commerce, Michigan
Reply With Quote
  #4  
Old 10-18-2014
al perna al perna is offline
Senior Member
 
Join Date: Oct 2009
Location: ormond fla
Posts: 2,258
Default

Thanks Bill & Dick,

at this point I agree and I need to start looking for structure damage . Not so easy to get under there lol . I did have a chance to check the pan rod and all connections are sound , looks like another trip down under is called for , not fun
__________________
AL & ERIKA

2000 LXI Single Slide (sold)
1999 Prevost Vantare 45

Ormond Beach, Florida
PLEASE DO NOT PM ME
alperna@yahoo.com
386 290 3444
www.fastcubes.com
Reply With Quote
  #5  
Old 10-18-2014
MarkYuma's Avatar
MarkYuma MarkYuma is offline
Not so Junior anymore
 
Join Date: May 2011
Location: Yuma
Posts: 1,397
Default

Quote:
Originally Posted by al perna View Post
Thanks Bill & Dick,

at this point I agree and I need to start looking for structure damage . Not so easy to get under there lol . I did have a chance to check the pan rod and all connections are sound , looks like another trip down under is called for , not fun
Javier ????????
__________________
Mark & Ginger Lauss
Yuma Arizona
1991 PT 40
Towed 1986 Suzuki Samurai OR 2014 Jeep jk
Location: http://www.bbirdmaps.com/user1.cfm?user=259
Reply With Quote
  #6  
Old 10-18-2014
Randy Dupree's Avatar
Randy Dupree Randy Dupree is online now
Forum owner
 
Join Date: Dec 2007
Location: Port St Joe,Fl
Posts: 35,708
Default

the 97 WB shares the same suspension as the LXI,I THINK.
the 96 and down are different for sure.

But,i don't think any of the WB's had a steering tag axle.(like your does)
They did have a lifting tag ,but not sure of all of them did.
__________________
DO NOT SEND PM
email me at randy@randydupree.com only.

Randy Dupree
2000 LXI 43
Bainbridge,Ga.
Port St Joe Fl.
www.buybyebluebird.com

randy@randydupree.com
Reply With Quote
  #7  
Old 10-19-2014
Mallie Lennon's Avatar
Mallie Lennon Mallie Lennon is offline
1995 WB 42’ Series 60
 
Join Date: Jan 2011
Location: Eufaula
Posts: 4,945
Default

Al, I know little on your situation, but is sure sounds like you have a leveling valve problem. Not responding as they should, or restriction in the air lines to the valves.
__________________
Mallie & Karen Lennon
Eufaula, Oklahoma
95 42' Wanderlodge
Please use e mail instead of Private Message
Mallie@EuLake.com
Reply With Quote
  #8  
Old 10-19-2014
Bill Pape's Avatar
Bill Pape Bill Pape is online now
Administrator
 
Join Date: Jan 2008
Location: Commerce
Posts: 11,428
Default

Quote:
Originally Posted by Mallie Lennon View Post
Al, I know little on your situation, but is sure sounds like you have a leveling valve problem. Not responding as they should, or restriction in the air lines to the valves.
I know a little less, but this seems a reasonably valid suggestion,
especially since Josam found nothing looking around the under belly with a flash light.
__________________
Bill & Patty
1988 FC, Silver Edition
Commerce, Michigan
Reply With Quote
  #9  
Old 10-19-2014
Crit Bliss's Avatar
Crit Bliss Crit Bliss is online now
Senior Member
 
Join Date: Jan 2008
Location: Cape Cod
Posts: 4,062
Default

HCV's are sketchy these days, I have replaced a valve and had the new one be junk too.
__________________
Crit Bliss
'80FC33
250T
Cape Cod,ma
Reply With Quote
  #10  
Old 10-19-2014
al perna al perna is offline
Senior Member
 
Join Date: Oct 2009
Location: ormond fla
Posts: 2,258
Default

Man you can not imagine how many HCV s I have had installed and installed on my own . No doubt some time is needed under her to really start checking the structure components for damage .
when she was doing her rolling on us in the summer, I said to the Prevost shop "just replace the HCV " after a couple hours, he said, " take a look at this" . This is when we discovered the Pan rod damage .

Randy, you know I do think in some way the inoperable Steer Tag must be in play here .

Mark , I really wouldn't t want to wait till Jan and drive another 7k miles or so lol
__________________
AL & ERIKA

2000 LXI Single Slide (sold)
1999 Prevost Vantare 45

Ormond Beach, Florida
PLEASE DO NOT PM ME
alperna@yahoo.com
386 290 3444
www.fastcubes.com
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
suspension hturner 12 Tires, Wheels, Brakes, Steering and Suspensions 2 05-29-2009 06:17 PM
Suspension iamflagman Tires, Wheels, Brakes, Steering and Suspensions 0 04-08-2008 12:56 AM
Suspension won't air up? thomas_sorrentino PT & WB (Twin Axle Pusher Unique Issues) 3 01-17-2008 11:47 PM

Web Search:

All times are GMT -4. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.