Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > M380 (Unique Issues)

M380 (Unique Issues) If you have a unique issue with your M380 model coach and it can't be answered in one of the other forums here, then this is where you can list it.....list your M380 Parts here too.

Site Search:
Reply
 
Thread Tools
  #111  
Old 08-22-2019
DonB's Avatar
DonB DonB is offline
Geek
 
Join Date: Jan 2008
Location: Eureka
Posts: 4,336
Default

Quote:
Originally Posted by RVinCT View Post
What I'm not sure is where the PRX1 gets its data. Is it the sensor that drives the gauges
Since the PRX1 drives the front gauge, at least, it would have to be that one. Sensor drives PRX1, PRX1 drives gauge. Pin 15 on the PRX1 is Oil Pressure Analog Input, which means it can't be a switch.
__________________
Don Bradner
Current: No RV at this time
2015 Jeep Grand Cherokee
Prior: 2004 M380 Double Slide
Prior: 1990 WB40 "Blue Thunder"
My location: www.bbirdmaps.com/user2.cfm?user=1
Reply With Quote
  #112  
Old 08-22-2019
RVinCT's Avatar
RVinCT RVinCT is offline
Senior Member
 
Join Date: Jan 2018
Location: Rockfall
Posts: 400
Default

Quote:
Originally Posted by DonB View Post
Thank You! Thank You!
__________________
Todd and Karen Pattist
Rockfall, CT
2007 Double Slide M380 "Bertie"
Reply With Quote
  #113  
Old 08-22-2019
Dc2x4drvr's Avatar
Dc2x4drvr Dc2x4drvr is offline
Senior Member
 
Join Date: Jan 2015
Location: JAX Based
Posts: 1,400
Default

So, ECM not PRX is the oil pressure low shutdown?
__________________
Lance & Linda Hall
2004 M380
Body #W000234
"Smooth Ride"
Full Timing with 2 cats

Last edited by Dc2x4drvr; 08-22-2019 at 08:38 PM. Reason: Disregard
Reply With Quote
  #114  
Old 08-22-2019
DonB's Avatar
DonB DonB is offline
Geek
 
Join Date: Jan 2008
Location: Eureka
Posts: 4,336
Default

Quote:
Originally Posted by Dc2x4drvr View Post
So, ECM not PRX is the oil pressure low shutdown?
There is no proof of any oil pressure low shutdown. Look at minutes 42 and 44 in his latest test. Good pressure, shutdown with an error message of loss of 12V power.
__________________
Don Bradner
Current: No RV at this time
2015 Jeep Grand Cherokee
Prior: 2004 M380 Double Slide
Prior: 1990 WB40 "Blue Thunder"
My location: www.bbirdmaps.com/user2.cfm?user=1
Reply With Quote
  #115  
Old 08-23-2019
RVinCT's Avatar
RVinCT RVinCT is offline
Senior Member
 
Join Date: Jan 2018
Location: Rockfall
Posts: 400
Default

Quote:
Originally Posted by DonB View Post
There is no proof of any oil pressure low shutdown. Look at minutes 42 and 44 in his latest test. Good pressure, shutdown with an error message of loss of 12V power.
After reviewing the FC434 info, I agree. The mechanical gauge is telling me I have good oil pressure and the shutdowns are not closely related to idle low pressure. The buzzer and inaccurate gauge are annoying, but don't seem directly to cause the shutdown. I can deal with them later.

So, I need to work on the 434 problem. Step 1 is to find the ECM/ECU. Where is it? I've looked in the engine compartment, the rear PDU in the engine battery compartment, in the front compartment under the driver's window and in the compressor compartment.

The compressor compartment has an Allison 3000 ECU (I assume transmission) and a Bendix ECU (I assume brakes), both silver. It also has the PRX (blue), although mine is marked PRX2-A.

The FC434 guide shows an ECU with three connectors. They are in the same position as the three connectors on the Allison. Is that it? Are the tranny and engine ECU combined? The schematic wiring doesn't seem to match.

Step 2 is to verify I have no injector error codes. The RR4 has a code "SID 51 Inact 1 Engine Controller Subsystem ID #51 Voltage>Normal". Can anyone identify it?

The Silverleaf has "SID 51 51 Auxiliary Output Dev Driver
#3 High Voltage". and "SID 251 50 Power Supply Invalid data" codes that relate to power as well as 175/30, 180/11, 191/56, and 115/77 codes that seem less relevant. (See my photos on page 3). Can anyone tell me if those are "injector fault codes"?
__________________
Todd and Karen Pattist
Rockfall, CT
2007 Double Slide M380 "Bertie"
Reply With Quote
  #116  
Old 08-23-2019
RVinCT's Avatar
RVinCT RVinCT is offline
Senior Member
 
Join Date: Jan 2018
Location: Rockfall
Posts: 400
Default

Cummins helped find the ECU. It's on the engine, behind/beside the fuel filter. They can't identify any codes other than FC434.
__________________
Todd and Karen Pattist
Rockfall, CT
2007 Double Slide M380 "Bertie"
Reply With Quote
  #117  
Old 08-23-2019
Dc2x4drvr's Avatar
Dc2x4drvr Dc2x4drvr is offline
Senior Member
 
Join Date: Jan 2015
Location: JAX Based
Posts: 1,400
Default

Disconnect the batteries to clear the code, see if the code comes back.
__________________
Lance & Linda Hall
2004 M380
Body #W000234
"Smooth Ride"
Full Timing with 2 cats
Reply With Quote
  #118  
Old 08-23-2019
DonB's Avatar
DonB DonB is offline
Geek
 
Join Date: Jan 2008
Location: Eureka
Posts: 4,336
Default

His RR is incrementing the code each times it happens, latest was the 4th.
__________________
Don Bradner
Current: No RV at this time
2015 Jeep Grand Cherokee
Prior: 2004 M380 Double Slide
Prior: 1990 WB40 "Blue Thunder"
My location: www.bbirdmaps.com/user2.cfm?user=1
Reply With Quote
  #119  
Old 08-23-2019
DonB's Avatar
DonB DonB is offline
Geek
 
Join Date: Jan 2008
Location: Eureka
Posts: 4,336
Default

I was wrong about it telling you to turn the key off and leaving it off for 5 seconds before restarting. What 434 was telling you was that:


the key was turned off, then back on, too fast for the computer to properly shutdown. Don't do that, always wait at least 5 seconds before restarting! (my wording, obviously).


So it comes back to ignition key wiring, with a momentary loss of connection that the computer did not appreciate, so it shut you down.


What we know is that your ignition wiring is screwed up, probably just another in the long list of things your dealer did badly before delivery, such that a) you can't start from the rear, and b) you can start up front with the hood up, and c) (probably) wherever they cut the wires to the rear ignition and hood inhibit is a poor connection.
__________________
Don Bradner
Current: No RV at this time
2015 Jeep Grand Cherokee
Prior: 2004 M380 Double Slide
Prior: 1990 WB40 "Blue Thunder"
My location: www.bbirdmaps.com/user2.cfm?user=1
Reply With Quote
  #120  
Old 08-23-2019
RVinCT's Avatar
RVinCT RVinCT is offline
Senior Member
 
Join Date: Jan 2018
Location: Rockfall
Posts: 400
Default

I found another RV owner with 434 codes and engine shutdowns. He found a bad connector to +12v. I'm having trouble finding the "23 pin" OEM connector and the fuses (it helps to look up the right code, "434" not "454"), but I'm on the right track.

I was surprised to learn my engine was built in 2003. It's a 2007 vin with a 2006 chassis build date.
__________________
Todd and Karen Pattist
Rockfall, CT
2007 Double Slide M380 "Bertie"
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 with check engine light. Randy Dupree Engine 4 04-05-2017 06:51 PM
DDEC 1 Check Engine Light Confusion Alfa Engine 4 08-25-2016 09:20 PM
Check engine light info redburk Electrical 54 11-09-2014 11:45 AM
check engine light atckip Engine 7 06-01-2010 09:50 PM
Check Engine Light 8V92 Jim Barone Engine 8 05-04-2008 08:29 PM

Web Search:

All times are GMT -4. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.