Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > LX and LXI (Unique Issues)

LX and LXI (Unique Issues) If you have a unique issue with your LX or LXI model coach and it can't be answered in one of the other forums here, then this is where you can list it, WITH THE EXCEPTION OF THOSE ISSUES INVOLVED WITH ANY LAWSUIT.....list your LX and LXI Parts here too.

Site Search:
Reply
 
Thread Tools
  #1  
Old 09-05-2016
AllenG AllenG is offline
Junior Member
 
Join Date: Jul 2014
Location: Livingston
Posts: 16
Default 12.5 PowerTech W/ Isuzu Engine

Genny ran all day yesterday without a problem and now engine will not start.

When I turn on the genny the "timer" light illuminates and you can hear a buzzing sound but the start up process do not go any further.

I removed the top of control box (on top of unit) and notice the Bosch relay is the source of the sound. (The manual is a bad photo copy of what appears to be originally printed on a ditto machine. ) What I can read and surmise there are three relays 1) Pre-heat relay 2)run relay 3) starter relay. The preheat relay is the source of the vibration and sound.

Here is what I have tried
1) cleaned positive & negative post
2) Moved Bosch relay to different position. The issue is always with portion 1 preheat buzzing and the start up process not moving on.
3) Checked and cleaned glow plugs. All 3 passing current.
4) No loose or broken wires in control box.
5) Go to the WOG because I am out of ideas.
__________________
Allen Golec

2000 LX 40 "[URL="http://www.wanderlodgeownersgroup.com/forums/www.beachnest.net"]The Beach Nest[/URL]"
2010 Sprinter "Road Runner"
2014 Homesteder 8" trailer "The Egg"
Reply With Quote
  #2  
Old 09-05-2016
Rick's Avatar
Rick Rick is offline
Senior Member
 
Join Date: May 2009
Location: Bellefonte
Posts: 13,226
Default

Quote:
Originally Posted by AllenG View Post
Genny ran all day yesterday without a problem and now engine will not start.

When I turn on the genny the "timer" light illuminates and you can hear a buzzing sound but the start up process do not go any further.

I removed the top of control box (on top of unit) and notice the Bosch relay is the source of the sound. (The manual is a bad photo copy of what appears to be originally printed on a ditto machine. ) What I can read and surmise there are three relays 1) Pre-heat relay 2)run relay 3) starter relay. The preheat relay is the source of the vibration and sound.

Here is what I have tried
1) cleaned positive & negative post
2) Moved Bosch relay to different position. The issue is always with portion 1 preheat buzzing and the start up process not moving on.
3) Checked and cleaned glow plugs. All 3 passing current.
4) No loose or broken wires in control box.
5) Go to the WOG because I am out of ideas.

Low voltage or bad ground at position one??
__________________
Rick Shawver
1SG Ret
2000 LX
Vise Grips
Bellefonte, AR
F127656
Reply With Quote
  #3  
Old 09-06-2016
rshrimp rshrimp is offline
Senior Member
 
Join Date: Apr 2016
Location: Myakka City
Posts: 1,516
Default

Sounds like a possible battery issue to me. That's how mine started. No crank condition.
I replaced the battery and it ran for a day. Then I found it had a bad alternator. ($60 on Ebay) Changed that and charged the battery and it cranked but wouldn't start. Bad glow plug relay, Changed all 3. Then it started 3 times and now the starter is bad (Waiting on a new one now (Ebay $160) Don't buy parts from Powertech! (Alt $500 Starter $750)

What happened: Low voltage condition caused high amp draw and fried parts ..... lots of parts. The Isuzu needs glow plugs to start everytime and they put a big draw on the battery before the starter gets a chance. Letting it try to start on a low battery ( or bad ground) will fry stuff.
__________________
Randy and Sonya Shrimplin
FMCA# F457849
Livin' the dream, next door to the Drysdale's in Beverly Hills FL!
Birdless for now.
RShrimp@Yahoo.com
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
12.5 Powertech 3cyl Isuzu cranks but won't start rshrimp Generators 20 11-03-2016 05:01 PM
isuzu generator Jeff Generators 93 10-10-2014 04:07 PM
PowerTech 12KW 3-cyl Isuzu Genny won't start ironmike Generators 23 08-13-2010 01:21 AM
2003 Blue Bird Wanderlodge Lxi - Engine And Engine Cooling:engine:diesel Randy Dupree Vehicle and Equipment Recalls 0 12-17-2007 12:24 PM
2002 Blue Bird Wanderlodge Lxi - Engine And Engine Cooling:engine:diesel Webmaster Vehicle and Equipment Recalls 0 12-16-2007 10:36 PM

Web Search:

All times are GMT -4. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.