Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > Generators

Generators In this forum we will try to answer any of your questions about the different model generators that can be found on Blue Bird coach's.

Site Search:
Reply
 
Thread Tools
  #1  
Old 04-27-2009
sweeperman sweeperman is offline
sweeperman
 
Join Date: Dec 2007
Location: Union beach NJ
Posts: 300
Default Kohler gen wont start

After run my buss to Ohio and back to jersey with the gen running most of the time two weeks ago i went out to start the gen and nothing happens I slide the gen tray out and the red bracker buton was out I reset and tride again and after a short time it poped out again .batt volt was 12.8 what do I look for next THANKS Mark
__________________
Mark Dammann
1989WB Royal
1980FC33 Sold
Vienna OH
908 902 8379
Reply With Quote
  #2  
Old 04-27-2009
ernie ekberg
Guest
 
Posts: n/a
Default

Check the fuse
Reply With Quote
  #3  
Old 04-27-2009
sfedeli's Avatar
sfedeli sfedeli is offline
Senior Member
 
Join Date: Jan 2008
Location: Hershey
Posts: 3,190
Default

Mark,

I have some work in Monmouth Co, NJ that needs to be done next week. If you don't get it figured out by then, I'd be glad to stop by and take a look at it with you. I'd start by checking the wires and making sure that nothing had worn through on the insulation going to the preheat solenoid or wiring harness leading to the control panel.
__________________
Shane Fedeli
85PT40
Hershey, PA

"Savor the wine of youth, for it is a drink that can be consumed only once”
shanefedeli@gmail.com
717-645-4912
Reply With Quote
  #4  
Old 04-27-2009
warbucks13477's Avatar
warbucks13477 warbucks13477 is offline
Senior
 
Join Date: Jun 2008
Location: Vernon Center
Posts: 1,302
Default

Mark remember the old KISS principle, keep it simple stupid. In other words look for the simple things first.
Open up the control box on the generator and tighten all of the screws on the terminal strips being careful to not short anything. The screws vibrate loose sometimes and cause the problem you are seeing.
You will trip the circuit breaker(red button) a lot of times when you shut down the generator with a load still on it or start it up with a load on it. When starting the generator make sure you have the shore power/generator etc switch in shore power and let the generator come up to speed for a few minutes then switch to generator. They normally dont like a big load thrown on them all at once. In other words turn your A/C off etc until the generator is running well then turn them on.

Those circuits are rather simple and I am sure Shane can help you with it if this does not work. Do you have a gas or diesel generator?
__________________
Tom Warner
Vernon Center,NY
1985 PT40 SOLD
6V92
Reply With Quote
  #5  
Old 04-28-2009
sweeperman sweeperman is offline
sweeperman
 
Join Date: Dec 2007
Location: Union beach NJ
Posts: 300
Default

Tom the gen is a diesel 12.5kw today I hope to find some time to look Its my busy time of the year with spring clean up sweeping and keeping 3 sweepers runing
Thanks mark
__________________
Mark Dammann
1989WB Royal
1980FC33 Sold
Vienna OH
908 902 8379
Reply With Quote
  #6  
Old 04-28-2009
Jim Barone Jim Barone is offline
Senior Member
 
Join Date: Jan 2008
Posts: 79
Default Kohler 12. 5 Genset

Mark...This is Jim Barone, fulltiming in a 1991 WBWL, currently in Savannah, Ga. I had a 12.5 Kohler in my boat...let me tell you about my starting problems and it may help you getting going...1st the Kohler requires a small load to be applied prior to starting such as a light or some other small load..has to due with exicting the fields...2nd take a look at the brushes at the end of the generator shaft...make sure the brushes are in good shape and that they are in contact with the armature(sp). 3rd make sure the armature is clean..it needs to be very clean and the brushes must be in contact with it..4th and most important, this was the problem with mine..there is a set of brushes that cannot be readily seen while looking at the other brushes..they are behind the frame towards the engine..once you know they are there they can be serviced..again check the brushes and clean the armature..this was the entire problem with my unit...hope this helps..Jim Barone
__________________
Jim and JoAnn Barone
1991 WLWB
Fulltiming in Tubac, Arizona
Reply With Quote
  #7  
Old 04-28-2009
warbucks13477's Avatar
warbucks13477 warbucks13477 is offline
Senior
 
Join Date: Jun 2008
Location: Vernon Center
Posts: 1,302
Default

Mark once someone goes over the generator drawings with you and the Kohler manual you can see that the generator is not very complicated and rather easy to troubleshoot. If it is running and stops and the circuit breaker (red button) is tripped then it could be caused by a couple of reasons however I doubt if it is anything serious. Remember it ran all the way home on your trip and just shutting it off probably would not have caused the problem. Did you have enough diesel fuel left (over 1/3 tank) in the fuel tank so the generator is not stopping because it is to low? Its a safeguard that BB put in the design of the coach so you could not run the diesel fuel entirely out using the generator and then could not start the Cat engine to get to more fuel.
The circuit breaker could have popped simply because the engine shut off with a load on it.

Did you try to start the generator from the control box and when you tried did the fan motor start to turn? If so the generator is putting out voltage. Did you check the oil level? If there is no oil pressure you can start the engine but it will immediately shut down. Have you cleaned and reoiled the air cleaner in the past year or so? If you have someone hold in the fuel solenoid can you start it and then run it (check and make sure you have oil first)?

But I would still take the cover off the control box first and tighten all of the terminal strip screws. Bet thats your problem.

If that does not work and Shane cant fix it then come to the rally and caravan along with tom Sorrentino here. We can fix it and show you everything about it so next time you can fix almost any problem. Tom Sorrentino can show you how easy it is to replace the slip rings and brushes. There is a trick involved to easily do it.
__________________
Tom Warner
Vernon Center,NY
1985 PT40 SOLD
6V92
Reply With Quote
  #8  
Old 04-28-2009
sweeperman sweeperman is offline
sweeperman
 
Join Date: Dec 2007
Location: Union beach NJ
Posts: 300
Default

tom I opened the control box and tighted the lugs I made shure all the loads were off. then i fliped the remote swich on i can here the top clear plastic relay close noting hapeneds. 30 sec or so red buton pops out .but here is the weird the thing i reset red buton and turn on remote switch jump the two big studs on the starter relay in the control box perkins starts right up and gen cooling fan runs so does an roof a/c let run 20 min or so turn of ac and turn of gen. wait 10 min turn on start switch nothing 30 sec or so red buton pops out so some thing must have a lose or bad con on the start side in the control box
Thanks mark btw my phone # is 732 739 2482 I talk a little better than I can typ
__________________
Mark Dammann
1989WB Royal
1980FC33 Sold
Vienna OH
908 902 8379
Reply With Quote
  #9  
Old 04-29-2009
sweeperman sweeperman is offline
sweeperman
 
Join Date: Dec 2007
Location: Union beach NJ
Posts: 300
Default

update: when I turn on the start switch on the contol box the lower red wire to the perkins start selonid does not have power. Now if I jump from battery positve to the red wire on perkins start selonid whith contol panel switch on run engine starts and generator makes power fine. Is it possible that the clear plastic relay box (marked CR) is bad? Shane might take you up on your offer, if your in my area in jersey next week You can call me anytime (732) 739-2482
__________________
Mark Dammann
1989WB Royal
1980FC33 Sold
Vienna OH
908 902 8379
Reply With Quote
  #10  
Old 04-29-2009
warbucks13477's Avatar
warbucks13477 warbucks13477 is offline
Senior
 
Join Date: Jun 2008
Location: Vernon Center
Posts: 1,302
Default

mark a good rule of thumb is to always have at least one of every relay in the control box and even for inside the coach. For the relays read the nomenclature off the relay and order a new one from www.digikey.com they do not cost much. If you do not have them I can dig up my list and give it to you. Most of the ones in my control box for the 1982 FC35 were metal bosc relays.
__________________
Tom Warner
Vernon Center,NY
1985 PT40 SOLD
6V92
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP - 8V92 will not start LarryKehler Engine 14 01-13-2019 09:09 PM
37' BMC,will not start Randy Dupree Engine 5 04-08-2009 05:34 PM
Engine wont start on chassis battery lonestar382 Engine 3 01-04-2009 07:02 PM
84 PT no start BusBoyJj Engine 7 05-29-2008 06:35 PM
Xantrex installed, Redi-line removed - now wont start... Robmk2 Electrical 6 02-17-2008 09:26 AM

Web Search:

All times are GMT -4. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.