Wanderlodge Owners Group  
BuyByeBlueBird.com
Donate

Go Back   Wanderlodge Owners Group > Mechanic's Corner > M380 (Unique Issues)

M380 (Unique Issues) If you have a unique issue with your M380 model coach and it can't be answered in one of the other forums here, then this is where you can list it.....list your M380 Parts here too.

Site Search:
Reply
 
Thread Tools
  #1  
Old 05-01-2019
mikeocd mikeocd is offline
Senior Member
 
Join Date: Oct 2016
Location: Monson
Posts: 111
Default HELP will not Start

Let me try to be as thorough as possible. We drove back North from Florida the 1st week of march, stopped at 3 places for 2 days each we had no problems. When we got home I parked the rig in the driveway and shut her down, turned off both master switches Starting batteries and 12 volt. 2 Weeks later turned everything back on started up with no problems, drove her to my body shop where I am getting some repairs done. Shut her off using both master switches again. About 3 weeks later when is was her turn for the work, I turned on the master switches and try to start her and would not start. She turns over slowly then has a clicking sound as if she is not getting enough juice. Charged the Batteries overnite still nothing, Tried to jump her off the truck still nothing, Genny same thing. (meter was reading 12.7 all the back to the starter) After reading as many posts as possible I decided to take the Batteries out bring to Napa and have them load tested, The Batteries came back perfect, 12.7 V. I cleaned all terminal and connections all the way to the started including the ground on the frame. Still the same thing happened. I checked the fuses and I am no mechanic by any means but everything looked fine, I feel like it is something small that I am missing, any ideas would be appreciated, Thanx.
__________________
Mike Richard
Monson, Massachusetts
2004 M 380
2004 PT Cruiser

USMC 0311
DAV Life Member
Reply With Quote
  #2  
Old 05-01-2019
Rick's Avatar
Rick Rick is offline
Senior Member
 
Join Date: May 2009
Location: Bellefonte
Posts: 13,226
Default

Other 12 volt stuff work? Headlights, Inverter, etc? What happens with the voltage gage when you hit the starter? How far does it drop
__________________
Rick Shawver
1SG Ret
2000 LX
Vise Grips
Bellefonte, AR
F127656
Reply With Quote
  #3  
Old 05-01-2019
mikeocd mikeocd is offline
Senior Member
 
Join Date: Oct 2016
Location: Monson
Posts: 111
Default

yes everything else seems to work and the volts drop to around 10 when i try to start it..
__________________
Mike Richard
Monson, Massachusetts
2004 M 380
2004 PT Cruiser

USMC 0311
DAV Life Member
Reply With Quote
  #4  
Old 05-01-2019
Randy Dupree's Avatar
Randy Dupree Randy Dupree is offline
Forum owner
 
Join Date: Dec 2007
Location: Port St Joe,Fl
Posts: 36,871
Default

check your email.
__________________
DO NOT SEND PM
email me at randy@randydupree.com only.

Randy Dupree
2000 LXI 43
Bainbridge,Ga.
Port St Joe Fl.
www.buybyebluebird.com

randy@randydupree.com
Reply With Quote
  #5  
Old 05-01-2019
SAFCO SAFCO is offline
Senior Member
 
Join Date: Aug 2017
Location: Hampden
Posts: 268
Default

Randy is on the case, I feel better.
Where is your bird Mike? You have a local mechanic ?
__________________
Stuart Fearn
East Longmeadow, MA
2000 LXi Millennium Edition, Single slide
stuart@safcofoam.com
Reply With Quote
  #6  
Old 05-01-2019
mikeocd mikeocd is offline
Senior Member
 
Join Date: Oct 2016
Location: Monson
Posts: 111
Default

Its in Palmer, im going to try something Randy said I will keep you posted..
__________________
Mike Richard
Monson, Massachusetts
2004 M 380
2004 PT Cruiser

USMC 0311
DAV Life Member
Reply With Quote
  #7  
Old 05-01-2019
SAFCO SAFCO is offline
Senior Member
 
Join Date: Aug 2017
Location: Hampden
Posts: 268
Default

ok call me if you need to
__________________
Stuart Fearn
East Longmeadow, MA
2000 LXi Millennium Edition, Single slide
stuart@safcofoam.com
Reply With Quote
  #8  
Old 05-01-2019
AEmedic AEmedic is offline
Senior Member
 
Join Date: Jul 2016
Location: Boise
Posts: 291
Default

Clicking usually is a low/bad battery or a poor connection. Some times it’s the connection to the starter and could be the starter drawing too many amps. Since you have checked the batteries, check the starter connection.
__________________
Chris Rogers
Boise, Idaho
2004 M380 DS
Jeep TJ Toad - LS 5.3 swap in process
Reply With Quote
  #9  
Old 05-01-2019
Bill Pape's Avatar
Bill Pape Bill Pape is offline
Administrator
 
Join Date: Jan 2008
Location: Commerce
Posts: 11,674
Default

Check starter connections, Especially if it has a braided ground strap
__________________
Bill & Patty
1988 FC, Silver Edition
Commerce, Michigan
Reply With Quote
  #10  
Old 05-01-2019
mikeocd mikeocd is offline
Senior Member
 
Join Date: Oct 2016
Location: Monson
Posts: 111
Default

i took both cables of the starter cleaned them and replaced them today, i dont believe it has a braided cable
__________________
Mike Richard
Monson, Massachusetts
2004 M 380
2004 PT Cruiser

USMC 0311
DAV Life Member
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another no start kylep9 PT & WB (Twin Axle Pusher Unique Issues) 31 09-07-2016 06:06 PM
85 FC Won't Start jerpicard FC (Forward Control Unique Issues) 29 09-02-2016 09:13 PM
NO START streetrodder SP (Single Axle Pusher Unique Issues) 43 04-08-2013 11:13 AM
Now the Cat Won't Start Hoagie Engine 10 10-17-2011 04:33 PM
would not start Don Meyer Engine 3 06-05-2010 10:39 AM

Web Search:

All times are GMT -4. The time now is 06:35 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.